Thread: Non-critical data recovery question: USB key showing 0 bytes

Reply to Thread
Results 1 to 3 of 3
  1. #1 Non-critical data recovery question: USB key showing 0 bytes 
    Senior Member Karim D. Ghantous's Avatar
    Join Date
    Oct 2011
    Location
    Melbourne AU
    Posts
    1,794
    I'd like a bit of help with a USB key that shows 0 bytes capacity and 0 bytes free on Windows PCs. It does not seem to show up in either Linux Mint (recent version) or Mac OS 10.9.5. I tried Disk Utility on Mac OS X and it does not appear.

    If I insert the USB key into a PC with either Windows 7 or Windows 98, an icon for the volume shows up (in Windows 7 it's kind of greyed out, sort of). If I double-click on the icon, it asks me to insert a disk into the drive, so it seems to assume that the USB key is a removable media reader or something. It doesn't show up in Disk Defragmenter. I tried to insert it into a Windows 10 PC and the volume's icon very briefly appeared before disappearing.

    Any ideas? I would appreciate any tips you might have. I have not had to worry about data recovery before. Thankfully there is nothing too important on this volume. But the information will be useful down the line, for sure. I never put important things on solid state disks anyway, so it's not a huge loss.

    I will post screenshots tomorrow if it will help.
    Good production values may not be noticed. Bad production values will be.
    Pinterest
    | Flickr | Instagram | Martini Ultra (blog)
    Reply With Quote  
     

  2. #2  
    Senior Member Blair Thornton's Avatar
    Join Date
    Oct 2013
    Location
    Toronto
    Posts
    345
    My guess is the USB stick's memory is bad.
    Reply With Quote  
     

  3. #3  
    Sounds like a bad USB stick. Data recovery software would not be of use, if the stick cannot be recognized by any computer. The software needs to be able to "see" the stick, to be able to scan it. If the data is important to you, at this point, professional recovery would be the next step.
    Reply With Quote  
     

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts