Thread: Has anyone used the MAXOAK V mounts on their Dragon?

Reply to Thread
Results 1 to 5 of 5
  1. #1 Has anyone used the MAXOAK V mounts on their Dragon? 
    Multiple hat wearing director and cinematographer based but not bound in the greater New York area.
    -
    GEMINI
    -
    Website: julienjarry.com
    Reel: https://vimeo.com/user5908197
    Instagram: instagram.com/julienajarry/
    Youtube: youtube.com/user/jjair24
    Reply With Quote  
     

  2. #2  
    Senior Member
    Join Date
    Jan 2012
    Location
    Seattle, WA USA
    Posts
    306
    Killer bats! Great bargain.
    Epic-M Dragon #1271
    Reply With Quote  
     

  3. #3  
    Senior Member
    Join Date
    Jan 2008
    Location
    Los Angeles
    Posts
    531
    I have had 4 for a year and very happy on Dragon.
    Reply With Quote  
     

  4. #4  
    Member
    Join Date
    Jul 2016
    Location
    Los Angeles
    Posts
    31
    Good to know these work with Reds.
    This past year I bought two of these and they work great if anyone else is looking as well. Charged them on my paglink charger without a problem.

    https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1
    Reply With Quote  
     

  5. #5  
    Senior Member
    Join Date
    Apr 2007
    Location
    Marina Del Ray
    Posts
    704
    Had 4, only 2 worked on Red and that was just for about 2 months. The camera would always go off with the slightest shake, which rules out any form of handheld work. However, the seller did refund 50% and allowed me to keep them, so I only used them for my LED panel lights and BM Ursa mini cameras. On life span, I'd say don't expect more than 18months. All 4 I had never made it to 2 years. I would recommend Dynacore if you are on a budget
    Scarlet MX
    2 RAVENs
    2 GEMINI
    MONSTRO
    Reply With Quote  
     

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts