Thread: RED Epic W damaging 2 x Red 5" TS Monitor during FW upgrade!

Reply to Thread
Results 1 to 8 of 8
  1. #1 RED Epic W damaging 2 x Red 5" TS Monitor during FW upgrade! 
    Member Igor Vranjkovic's Avatar
    Join Date
    Dec 2008
    Location
    Serbia & Croatia
    Posts
    32
    During an beta FW upgrade our Epic W Helium Camera damaged our two RED 5” TS Monitors!
    After the upgrade, the first monitors mounted on the camera went blue .. we thought this might be an bug and restarted the camera but the picture was still bluish…
    So we tried to roll back but unfortunately with the same results.
    After few minutes we upgraded the camera again and this time we mounted our second Red 5” monitor. Now the picture on the second Monitor went Magenta!
    The Camera had les then 100 working hours and was under Red Armor protection.
    After sending the .log file RED Service asked to ship the camera and the monitors for repair.
    The diagnose from RED is IOB Board on the camera was damaged... This obviously caused the damage on the (2) RED 5” TS,
    And the worst thing comes..
    The (2) RED Touch 5.0 are unfortunately irreparable!!!
    Btw. Our camera is still at RED, since end of September!
    That’s service…
    Reply With Quote  
     

  2. #2  
    Banned
    Join Date
    Jul 2016
    Posts
    64
    yeah , I paid for a replacement I/O board before I upgraded from epic -x to dragon
    then a few months later , after a system check before selling the camera .. the same board needed changing

    its not a cheap board , and they seem to last about 3 months .. igor .. learn from this .. little chance things will improve until red' arrogance levels decline .. their hardware is flakey at best

    hope they sorted your camera out .. and I hope you enjoy replacing the same board repeatedly once the armor runs out .. that's if they don't discontinue the camera all together of course
    Reply With Quote  
     

  3. #3  
    Senior Member
    Join Date
    Aug 2010
    Posts
    504
    I think the same thing just happened to me on two 5" touches: how is this possible?! The screens work but the touch facility & being able to use them to operate the camera is not happening & yes red say that can't repair them any more.

    :(

    Craig Lees
    UK
    Reply With Quote  
     

  4. #4  
    Member Igor Vranjkovic's Avatar
    Join Date
    Dec 2008
    Location
    Serbia & Croatia
    Posts
    32
    Quote Originally Posted by Craig Lees View Post
    I think the same thing just happened to me on two 5" touches: how is this possible?! The screens work but the touch facility & being able to use them to operate the camera is not happening & yes red say that can't repair them any more.

    :(

    Craig Lees
    UK
    Hi Craig,

    did your Camera damaged the Monitors during the FW Upgrade? If so, was your camera still under warranty?

    Best

    Igor
    Reply With Quote  
     

  5. #5  
    I am sorry to hear that Igor, butt it looks like you are not the only one with this. Hope for you the guys at Red are getting this solved soon.

    What i don't understand is why people are banned when they writing about bad service or experience they had with RED! I mean this are costumers and they are spending a lot of money for your products , and this is the complain forum, or not?
    Reply With Quote  
     

  6. #6  
    Senior Member
    Join Date
    Dec 2014
    Posts
    149
    Is this only to the 5" monitors? I have the 7" DMSC2
    Red Epic W Owner.
    Reply With Quote  
     

  7. #7  
    Senior Member
    Join Date
    Sep 2015
    Location
    PDX || MSP
    Posts
    122
    Yikes, I'd send the camera/monitor in after that one.. I've had monitors go black and never restart due to cold. Never blue..
    Joshua VP Filming and Editing LLC.
    joshuavp.com

    RED EPIC WEAPON -- PDX || MSP
    Reply With Quote  
     

  8. #8  
    Senior Member
    Join Date
    Nov 2011
    Location
    San Francisco, CA
    Posts
    731
    Just wanted to chime in and say the same thing happened to me. A flawless, studio-use only 5.0 Touchscreen was irreparably damaged last month due to a firmware upgrade. Sent it in to RED and they couldn’t repair it. I’m fine with having to repair a 6 year old monitor but having it damaged by the gear itself, AND not being able to have it repaired? That was a kick in the nuts.
    @ajt4k

    ajt4k.com

    REDucated June 2012

    Scarlet-X #2098
    Raven #61
    Reply With Quote  
     

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts