Thread: OPTITEC NIKON PRO LOCK MOUNT FOR EPIC

Reply to Thread
Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11  
    Senior Member Josh Becker's Avatar
    Join Date
    Mar 2013
    Location
    Minneapolis, MN
    Posts
    828
    Wait, I'm confused, this looks like the same Optitek I've seen in other photos that people say works fine on DSMC2. Why would the iris gear need to be modified? There really isn't anything sticking out the front of DSMC2 to obstruct anything on this mount.

    I'm possibly interested, by the way!
    ---
    Epic-W #001633
    www.joshbecker.net
    Reply With Quote  
     

  2. #12  
    Senior Member Jacek Zakowicz's Avatar
    Join Date
    Jun 2008
    Posts
    3,289
    Quote Originally Posted by Josh Becker View Post
    Wait, I'm confused, this looks like the same Optitek I've seen in other photos that people say works fine on DSMC2. Why would the iris gear need to be modified? There really isn't anything sticking out the front of DSMC2 to obstruct anything on this mount.

    I'm possibly interested, by the way!
    You are correct Josh. The DSMC1 bottom V2 fan motor was the culprit. Not anymore ;-)
    Jacek Zakowicz, Optitek-dot-org, jacek2@optitek.org
    Professional Broadcast and Digital Cinema Equipment
    Reply With Quote  
     

  3. #13  
    Senior Member
    Join Date
    Aug 2007
    Location
    Tokyo, Japan
    Posts
    155
    Thank you Jacek for explaining this! I just wanted to contact you about this.
    Reply With Quote  
     

  4. #14  
    Senior Member
    Join Date
    Aug 2007
    Location
    Tokyo, Japan
    Posts
    155
    Bump
    Reply With Quote  
     

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts